arm-elf-gcc/arm-elf/ld images with Lauterbach Trace-32 emulator - file loading problem

Vincent Rubiolo
Thu Jun 19 08:54:00 GMT 2003


Has anyone been using Lauterbach emulators along with GNU tools?

I currently have problems with loading images generated by 
arm-elf-gcc/arm-elf-ld in the Trace-32 device.
I compiled a simple "hello world" program to check whether symbol/debug 
information was available.

Since this did not work and thought at first it was a problem with debug 
symbols, I tried different formats (stabs and dwarf2), with gdb specific 
information disabled.

However, the file cannot even load into the emulator so I think it is more a 
problem of section layout. I tried my own linker script along with ld default 
script for arm-elf-targets. None of them generated images that I could load in 
the emulator.

I must also mention that I tried /GNU, /DWARF and /STABS flags as well. No help.

The only message that the trace-32 is spitting out is:
"Error: entry near offset 89831. in file my_file (use DUMP)"
I could not get anything useful with the DUMP command as well.

Could anybody help me?

Thanks for your consideration,


Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list