Problem making gdb for powerpc-eabi architecture

Reed, Dan Daniel.Reed@akspace.com
Wed Jun 18 19:20:00 GMT 2003


On cygwin I made the gcc toolset for powerpc-eabi architecture. All good until I tried making the gdb. Here's a blurb from the buildlog that I captured. It seemed to choke running igen. I ran using both gdb-5.3 and again on gdb-5.2.1 (just in case). Same problem both sets. Any clues for what to look at? I have to admit that igen & the ppc-instructions file is a mystery to me.

My goal is to use psim with gdb.

Thanks,
Dan

output below
------------

./igen	 -E  -F 32,f,o -CSRI 1024 -N 5  \
	-o ../../../gdb-5.2.1/sim/ppc/dc-complex \
	-k ../../../gdb-5.2.1/sim/ppc/ppc-cache-rules \
	-I ../../../gdb-5.2.1/sim/ppc -i ../../../gdb-5.2.1/sim/ppc/ppc-instructions \
	-n icache.h    -hc tmp-icache.h \
	-n icache.c    -c  tmp-icache.c \
	-n semantics.h -hs tmp-semantics.h \
	-n semantics.c -s  tmp-semantics.c \
	-n idecode.h   -hd tmp-idecode.h \
	-n idecode.c   -d  tmp-idecode.c \
	-n itable.h    -ht tmp-itable.h \
	-n itable.c    -t  tmp-itable.c \
	-n model.h     -hm tmp-model.h \
	-n model.c     -m  tmp-model.c \
	-n support.h   -hf tmp-support.h \
	-n support.c   -f  tmp-support.c
	-E
	-F 32,f,o
	-C
	-S
	-R
	-I 1024
	-N 5
	-o ../../../gdb-5.2.1/sim/ppc/dc-complex
	-k ../../../gdb-5.2.1/sim/ppc/ppc-cache-rules
	-I ../../../gdb-5.2.1/sim/ppc
	-i ../../../gdb-5.2.1/sim/ppc/ppc-instructions
../../../gdb-5.2.1/sim/ppc/ppc-instructions:56: missing position field at `do { \
'
make[2]: *** [tmp-igen] Error 1
make[2]: Leaving directory `/cygdrive/d/gnutemp/build-gdb/sim/ppc'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/cygdrive/d/gnutemp/build-gdb/sim'
make: *** [all-sim] Error 2

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list