Build without libgloss?

Bruce Adams
Tue Sep 3 10:26:00 GMT 2002

> -----Original Message-----
> From: Werner Tuchan []
> Sent: 03 September 2002 09:38
> To: Bruce Adams
> Cc:
> Subject: Re: Build without libgloss?
> Bruce Adams wrote:
> >After some tinkering I can get as far as building newlib but it (the
> >build-crossgcc-sh script) fails whilst building 
> >libgloss in build-newlib/m68k-coff/m68000/libgloss/m68k with 
> "no targets
> >specified and no makefile found".  The
> >configure log seems to suggest its trying to use some 
> functions in libc.a
> >which we should have just built.  Has
> >anyone know how to resolve this problem?  
> >   I don't think we will require any of the routines in 
> libgloss for our
> >application as we already have our own low level
> >support code.  Is there some way to build newlib without 
> libgloss or is it
> >an integral part without which nothing else
> >will work?  The equivalent of running configure with 
> --without-libgloss
> >perhaps?
> >					Regards,
> >						Bruce A.
> >
> I didn't use Bill's script but the two pass build procedure 
> worked for 
> my target m68k-elf on gcc 3.2.
> If you don't need newlibs libgloss you can just move the 
> newlib sources 
> from newlib-1.10.0/newlib to gcc-3.2/newlib and configure and 
> build it 
> with gcc's build. It will compile gcc and newlib in one pass.
> gcc 3.2 produces an executable that will run on my target but my 
> debugger chokes on the new symbol information. If you use 
> anything else 
> than gdb for debugging and run into these problems you should 
> consider 
> gcc 2.95.3 instead.
Are you using cygwin with David Knuth's patch to the gcc source
and what configure options did you use?

I have tried this and various alternatives via modifications to the script

configure --host=i686-pc-cygwin --target=m68k-elf
--prefix=/cygdrive/c/gccm68k \
 --with-gnu-as --with-gnu-ld --enable-languages=c,c++ \
 --without-headers --with-newlib \ 
 --with-local-prefix=/cygdrive/c/gccm68k/m68k-elf --verbose

It seems to work 'better' with /cygdrive/c instead of c:
On one attempt the first pass install tried to use /c:/ and failed (another
one for the FAQ).

Something I read seemed to suggest the C library, be it newlib or glibc
should always be built as part of the gcc tree.  What is the current
wisdom on this?

I'm obvious doing something wrong.  Maybe someone could enlighten me with
some answers
to the following (admittedly most of which should be RTFM or STFW items).  I
have a least partial answers but independent verification would be nice.

How can I test my binutils are actually working?  
I've tried make check but I'm not sure if this is valid as I don't have
deja-gnu installed.

Why are --with-gnu-as & --with-gnu-ld necessary?
Which as and ld is it after and where will it look for them?

Which headers does --without-headers refer to? what is the relationship of
headers to the newlib ones?

					  Bruce A.

 Any opinions expressed in this e-mail are those of the individual and not
 necessarily those of Tyco Electronic Product Group.

 Any prices for the supply of goods or services are only valid if supported
 by a formal written quotation.

 This e-mail and any files transmitted with it, including replies and
 forwarded copies (which may contain alterations) subsequently transmitted
 from Tyco Electronic Product Group are confidential and solely for the use
 of the intended recipient.

 If you are not the intended recipient or the person responsible for
 delivery to the intended recipient, be advised that you have received this
 e-mail in error and that any use is strictly prohibited.  In this event,
 please notify us via e-mail at '' or telephone on 
 0121 255 6499 and then delete the e-mail and any copies of it.

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list