arm-elf-gcc memcpy builtin?

Richard Earnshaw
Tue Nov 5 02:11:00 GMT 2002

> It appears that our embedded ARM7 application is spending a
> significant amount of time is being spent inside memcpy.  I've
> tried everything I can think of to get gcc to use builtin
> memcpy code, but it just won't.
> I've tried various values of -O, I've added -fbuiltin, I've
> even tried explictly calling __builtin_memcpy().  Nothing
> works.  No matter what I do, gcc just loads up the parameters
> and makes a call to memcpy().
> Does the ARM back end not know how to do a built-in memcpy?
> $ arm-elf-gcc -v
> Reading specs from /usr/local/lib/gcc-lib/arm-elf/2.95.2/specs
> gcc version 2.95.2 19991024 (release)

The built-in memcpy will only be used if both the memory areas are word 
aligned and the transfer is less than 65 bytes.  It doesn't have to be a 
multiple of 4 bytes transferred.

At least, that's the current definition; I can't remember changing it in 
ages, so I guess 2.95 will be the same.


Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list