build problem for mipsisa32 xcompiler

Mon Nov 4 13:24:00 GMT 2002

On November 4, 2002 11:03 am, William A. Gatliff wrote:
> Henri:
> Add a --with-gnu-as and --with-gnu-ld to your gcc configure line.

many thanks , that problem was overcome with your suggestion

further down , the makefile stops with an error related to a -G option not 
accepted. As I understand this option is only related to the mips 
environment.  the host i686 "as" was probably called producing the error 

the question I have is how to force the configure script to use the cross 
assembler created in the binutils 

tried AS_FOR_TARGET=$i/${target}-as but still the same error message 

many thanks


path to the correct assembler to use: 

 ls -al /home/henri/tools/bin/mipsisa32-elf-as
-rwxr-xr-x    2 henri    henri     6098349 Nov  4 08:41 

error message: 
-B/home/henri/temporaire/build-gcc/gcc/ -B/home/henri/tools/mipsisa32/bin/ 
-B/home/henri/tools/mipsisa32/lib/ -isystem 
/home/henri/tools/mipsisa32/include -O2  -DIN_GCC -DCROSS_COMPILE   -W -Wall 
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -isystem ./include  
-G 0 -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc -I. -I. 
-I../../gcc-3.2/gcc -I../../gcc-3.2/gcc/. -I../../gcc-3.2/gcc/config 
-I../../gcc-3.2/gcc/../include -DL_m16addsf3 -xassembler-with-cpp -c 
../../gcc-3.2/gcc/config/mips/mips16.S -o libgcc/./_m16addsf3.o
as: unrecognized option `-G'
make[2]: *** [libgcc/./_m16addsf3.o] Error 1
make[2]: Leaving directory `/home/henri/temporaire/build-gcc/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory `/home/henri/temporaire/build-gcc/gcc'
make: *** [all-gcc] Error 2

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

More information about the crossgcc mailing list