XScale gcc

Vermeulen Jan Jan.Vermeulen@siemens.atea.be
Wed Jan 23 06:12:00 GMT 2002


Hi Kyle,

>I am building the xscale gnu tools using NetBSD 1.5.2 as the host.  I have
built binutils, >and tried building it and get the error:
>> I get an error:
>> checking whether the C compiler
>> (/temp/gcc/gcc/xgcc -B/temp/gcc/gcc/ -B/usr/loca
>> l/xscale/xscale-netbsd-elf/bin/
-B/usr/local/xscale/xscale-netbsd-elf/lib/ -
>> isys
>> tem /usr/local/xscale/xscale-netbsd-elf/include -g -O2 ) works... no
>> configure: error: installation or configuration problem: C compiler
cannot
>> create executables.
>> gmake: *** [configure-target-libiberty] Error 1
>> bash-2.05#

The way I see it here, is that you are trying to build a xscale
crosscompiler _targetting_ a netbsd operating system (which, of course, runs
on that xscale processor).

Are you sure this is what you want? (have you a NetBSD port to xscale or are
you planning on making one?)

Maybe it is best that you provide us with more information on your plans:

- Do you want a crosscompile toolset for a custom xscale board running an
own-made OS or a commercial OS?
- What are the versions of the packages you using (for example:
binutils-2.10.1, gcc-2.95.3, newlib-1.9.0) ?
- What are your commandlines for configure/make for binutils, gcc, ... ?

That way we can more quickly and clearly see the problem you are facing.

[guessing mode]
I guess that you installed the binutils and then tried to build the full gcc
from scratch.

This does not work, because the crosscompiler needs certain stuff from the
libraries.
But the libraries need the crosscompiler to build them.

So the solution is to make a bare bootstrap C compiler and build the
libraries with that, and only then make the full crosscompiler.

More info:
http://crossgcc.billgatliff.com/
[/guessing mode]

Best regards,
Jan

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list