Mulitlibs for arm-elf crossgcc

wearpos wearpos@ife.ee.ethz.ch
Thu Jan 17 13:44:00 GMT 2002


Hi

I would like to use gcc in our current project.

So i tried to build gcc 3.0.2 with newest newlib under cygwin.

I succeeded in building all the stuff except the interworking libs, both
libc (newlib) and gcclib.

I have an arm lib and a thumb lib. But no arm thumb-interwork nor a tumb
thumb-interwork.

I tried the following configure:

../gcc-3.0.2/configure --target=arm-elf --prefix=/usr/local --with-gnu-as --
with-gnu-ld --with-newlib --enable-languages=c,c++
--enable-multilib --enable-interwork --with-cpu=arm7tdmi

I uncommented these lines in gcc/config/arm/t-arm-elf:

# MULTILIB_OPTIONS    += mno-thumb-interwork/mthumb-interwork
# MULTILIB_DIRNAMES   += normal interwork
# MULTILIB_EXCEPTIONS += *mapcs-26/*mthumb-interwork*

configure works with no error...

As i try to build I get an error:
make[1]: Entering directory `/xgcc-arm/build-gcc_i/libiberty'
make[2]: Entering directory `/xgcc-arm/build-gcc_i/libiberty/testsuite'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/xgcc-arm/build-gcc_i/libiberty/testsuite'
make[1]: Leaving directory `/xgcc-arm/build-gcc_i/libiberty'
make[1]: Entering directory `/xgcc-arm/build-gcc_i/gcc'
Makefile:639: *** missing separator.  Stop.
make[1]: Leaving directory `/xgcc-arm/build-gcc_i/gcc'
make: *** [all-gcc] Error 2


Any hints????

Thanks a lot

Alex





------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sources.redhat.com



More information about the crossgcc mailing list