"powerpc-elf-ar : not found" and "libgcc2.a" problem (target 'mak e all' or 'make all-gcc')

Bertin, Philippe philippe.bertin@barco.com
Tue Oct 16 01:20:00 GMT 2001

Hello, again,

And (I start feeling guilty) thank you again for all your help. After
checking what was suggested, that's what was done : after now having removed
everything again (you never know ... at least, I never know), after having
installed again the binutils (should it really be 2.10 ? I continued to use
2.11, maybe erroneously, but I didn't think so ?), after then adapting PATH
to PATH=$PATH:$prefix/bin, after then downloading and installing (as Dave
suggested) gcc-core-2.95.3, I thought I could've compiled without any
problem. But again, after running configure --prefix=$prefix,
--target=$target -v, I still have the problem of unfound header files (I
refer to the end of this message for the last outputs of the make all-
script in gcc-core-2.95.3 directory).

As I understand from former comments, I should then install the
(newlib/glibc) header files ? But then, trying to install these (with the
same ./configure- options), I either run into 'unsupported glibc' for
Solaris (???), or I should use newlib of which, in my 'quest', I found
mention of a --with-newlib option to be given to the ./configure- script
(although this option isn't mentioned when I run ./configure --help).

Now my questions :
1. are these actions still correct ?
2. why does the crosscompiler still not compile only it's core ?
3. is it correct that glibc isn't supported on Solaris (2.6) ?
4. when using newlib, should I really add the option --with-newlib to the
./configure- script? And if so, what does this option exactly do ?

Thank you again for all your kind answers,


Philippe Bertin.

extract of the latest actions ...

make[3]: Entering directory `/data/users/phbe/cross/gcc-2.95.3/gcc'
rm -f tmplibgcc2.a
for name in _muldi3 _divdi3 _moddi3 _udivdi3 _umoddi3 _negdi2 _lshrdi3
_ashldi3 _ashrdi3 _ffsdi2 _udiv_w_sdiv _udivmoddi4 _cmpdi2 _ucmpdi2
_floatdidf _floatdisf _fixunsdfsi _fixunssfsi _fixunsdfdi _fixdfdi
_fixunssfdi _fixsfdi _fixxfdi _fixunsxfdi _floatdixf _fixunsxfsi _fixtfdi
_fixunstfdi _floatditf __gcc_bcmp _varargs __dummy _eprintf _bb _shtab
_clear_cache _trampoline __main _exit _ctors _pure; \
do \
  echo ${name}; \
-I/data/users/phbe/cross/executable/powerpc-elf/include -O2  -DCROSS_COMPILE
-DIN_GCC -DHAIFA  -DSVR4  -g -O2 -I./include   -g1  -DIN_LIBGCC2
-D__GCC_FLOAT_NOT_NEEDED    -mstrict-align -I. -I. -I./config -I./../include
-c -DL${name} \
       ./libgcc2.c -o ${name}.o; \
  if [ $? -eq 0 ] ; then true; else exit 1; fi; \
  powerpc-elf-ar rc tmplibgcc2.a ${name}.o; \
  rm -f ${name}.o; \
./libgcc2.c:41: stdlib.h: No such file or directory
./libgcc2.c:42: unistd.h: No such file or directory
make[3]: *** [libgcc2.a] Error 1
make[3]: Leaving directory `/data/users/phbe/cross/gcc-2.95.3/gcc'
make[2]: *** [stmp-multilib-sub] Error 2
make[2]: Leaving directory `/data/users/phbe/cross/gcc-2.95.3/gcc'
make[1]: *** [stmp-multilib] Error 1
make[1]: Leaving directory `/data/users/phbe/cross/gcc-2.95.3/gcc'
make: *** [all-gcc] Error 2

Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com

More information about the crossgcc mailing list