Powerpc-eabi, bootstrap compilers...

Joe Sislow flynn@cosmodog.com
Thu Oct 18 09:06:00 GMT 2001


Kai Ruottu wrote:

> > My question is why it's running into GLIBC references?  I specified --with-newlib
> > in the configuration.  Are these standard Linux libraries that it's ok to use?
>
>  For me this sounds like having problems with your native compiler/run-time libs
> installation, your compiler producing executables which needs the glibc-2.2.3 version
> for your installed '/lib/libc.so.6' but your current run-time library is not version
> the version 2.2.3...
>
>  In your case I would use the 'objdump -p powerpc-eabi-ar' and look at the last lines
> in the output. If this gives the 'GLIBC_2.2.3' there, you must fix your native compiler
> first to use some earlier glibc. If you now link against a 2.2.3-version of 'libc.so.6',
> the run-time version must be the same version. Sometimes there aren't dependencies and
> the executables will work ok with older 'libc.so.6's, sometimes they don't... The
> produced 'powerpc-eabi-ar' can be one of these cases...

Ok, after the dump, it says:
    Version References:
        required from libc.so.6:
            0x09691f73    0x00 04 GLIBC_2.1.3
            0x0d696910   0x00 03 GLIBC_2.0
            0x0d696911   0x00 02 GLIBC_2.1

Now, I must note, that I found out that most of the binutils, with the exception of as,
readelf, and gasp are having the aforementioned error.

So, what do I need to do to fix this?  I installed GLIBC_2.2.3 *after* getting this error,
so it should be default for my native compiler now, no?  I'm in unknown territory here as a
relative newbie to the whole gcc chain.  What steps should I take to make sure my native
gcc is running with the right version of GLIBC?


%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Joe Sislow
Cosmodog, Ltd.
joe@cosmodog.com




------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list