Powerpc-eabi, bootstrap compilers...

Joe Sislow flynn@cosmodog.com
Wed Oct 17 13:44:00 GMT 2001

"William A. Gatliff" wrote:

> Joe:
> > Ok, while I've been messing with other stuff, I decided to try out
> > doing a powerpc-eabi build, and I get the following error types (a
> > bunch of 'em) when trying to compile the bootstrap:
> > ---
> > powerpc-eabi-ar: error while loading shared libraries:
> > powerpc-eabi-ar: symbol fnmatch, version GLIBC_2.2.3 not defined in
> > file libc.so.6 with link time reference
> Man, what's up with that?  :^)
> You aren't doing a --with-headers=..., are you?

Nope...only thing I put in there when trying to build the compiler is
--disable-shared and --enable-cross.  I thought that maybe they were
messing things up,  but even removed, I get the error.  I went back to
check if there were any errors in the building of binutils, but nothing
was reported at all.

Weird thing was that that was the same error that powerpc--linux-gnu-ld
was giving me when I tried to link the simple program I showed earlier.
I'm updating glibc on my machine now to make sure, but I don't know
what's up.

> Have you looked at the build script on crossgcc.billgatliff.com?
> Powerpc-eabi builds clean with it, at least with gcc-2.95.3 and
> binutils-2.10.someting.  Binutils-2.11.2 should also work, at least
> except for the latest version of Cygwin (which I'm troubleshooting as
> we speak).

I'll try that next.  Of course, yes, I'm using binutils-2.11.2.  I was
wondering if that could be a problem as well.  I'm guessing that
something else is weirdly configured on my machine.

Joe Sislow
Cosmodog, Ltd.

Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com

More information about the crossgcc mailing list