Powerpc-eabi, bootstrap compilers...

William A. Gatliff bgat@saturn.billgatliff.com
Wed Oct 17 13:29:00 GMT 2001


Joe:


> Ok, while I've been messing with other stuff, I decided to try out
> doing a powerpc-eabi build, and I get the following error types (a
> bunch of 'em) when trying to compile the bootstrap:
> ---
> powerpc-eabi-ar: error while loading shared libraries:
> powerpc-eabi-ar: symbol fnmatch, version GLIBC_2.2.3 not defined in
> file libc.so.6 with link time reference

Man, what's up with that?  :^)

You aren't doing a --with-headers=..., are you?

Have you looked at the build script on crossgcc.billgatliff.com?
Powerpc-eabi builds clean with it, at least with gcc-2.95.3 and
binutils-2.10.someting.  Binutils-2.11.2 should also work, at least
except for the latest version of Cygwin (which I'm troubleshooting as
we speak).


b.g.
-- 
Bill Gatliff
bgat@billgatliff.com

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list