Newer gcc versions and m68k-coff?

Larry Gray larry@greenmotor.com
Thu Oct 11 12:41:00 GMT 2001


Hello,
	I got a cross-compiler working for m68k-coff with gcc-2.95.1, binutils-2.9.1 
and newlib-1.8.2. Now, I've got to set up another computer, so I thought I 
would use the newer versions, and I'm having trouble. I'm following "Getting 
Started with GNU", by William Gatliff, (an excellent document) and 
substituting m68k-coff for the target.
	My first combination was gcc-3.0.1, binutils-2.11.2, and newlib-1.9.0. All 
works fine until I tried to build the complete compiler. This stops, 
complaining about "can't build executables". I've searched the archives, and 
found that a bottle of wine and a clean directory would solve this, I tried 
both, with no luck.
	I then tried gcc-2.95.3, binutils-2.11.2, and newlib-1.9.0. Other than not 
being able to build the c++ compiler, this worked. However, when I try to 
build using the -m68000 flag, I get:

/tmp/ccgGZR2A.s: Assembler messages:
/tmp/ccgGZR2A.s:1101: Error: short branch with zero offset: use :w
/tmp/ccgGZR2A.s:1101: Error: invalid byte branch offset

I can compile without this flag, but cannot run on the 68EZ328 (68EC000 
instruction set).

This is error is generated with code that compiles and runs fine with the 
older versions.

Has anyone else seen this? Should I give up and go back to the older versions?

Thanks in Advance,
Larry Gray
larry@greenmotor.com

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list