Undefined versioned symbol name __xstat64@@GLIBC_2.2

William A. Gatliff bgat@saturn.billgatliff.com
Thu Oct 4 07:54:00 GMT 2001


Guys:


[I posted this to bug-glibc a few days ago, didn't get a response.]


I'm trying to build a solaris2.8-hosted i386-linux toolchain.  When I
build the i386-linux glibc-2.24 or glibc-2.2.2, I get this error
(reformatted for clarity):

...

i386-linux-gcc -nostdlib -nostartfiles -shared -o \
/export/home/bgat/sun1/build-glibc/elf/ld.so \
/export/home/bgat/sun1/build-glibc/elf/librtld.os \
-Wl,--version-script=/export/home/bgat/sun1/build-glibc/ld.map \
-Wl,-soname=ld-linux.so.2

/export/home/bgat/H-sparc-sun-solaris2.8/i386-linux/bin/ld:
/export/home/bgat/sun1/build-glibc/elf/ld.so: undefined versioned
symbol name __xstat64@@GLIBC_2.2
/export/home/bgat/H-sparc-sun-solaris2.8/i386-linux/bin/ld: failed to
set dynamic section sizes: Bad value
collect2: ld returned 1 exit status
make[2]: *** [/export/home/bgat/sun1/build-glibc/elf/ld.so] Error 1
...

My build setup is as follows:

generic solaris2.8 setup, with GNU make, sed, awk, shutils, and native gcc

My cross toolchain looks like this:

binutils 2.10.1 (also tried 2.11.2, with same error)
gcc-2.95.3
glibc-2.2.4 and 2.2.2 (both with linuxthreads)
linux 2.4.3

The i386-linux-gcc referenced in the error message is the
solaris-hosted bootstrap compiler, <shameless plug> built from the FAQ
</shameless plug>.

I'm stuck.  It isn't totally clear to me what the actual error is, or
how to correct it.  I suspect I'm missing a few entries in some kind
of symbol version file deep inside glibc, but that's just speculation
on my part.  Grepping around in the sources hasn't uncovered anything
blatantly obvious or broken to me.

Suggestions?

As a sanity check, I have successfully built a i386-linux-hosted i386-linux
toolchain using the same build script.  Wierd.


Thanks!


b.g.
--
Bill Gatliff
bgat@billgatliff.com

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list