uClinux/arm-elf-linux

John Andrews john@triscend.com
Sat Mar 24 22:26:00 GMT 2001


Thanks for the paragraphs Bill!

I hope you write that book, lay claim to your O'Reilly animal now, they're
going fast 8-)

I've got an arm-elf-gcc, built with newlib.

When I try to build uClibc or newlib with it I get the reading.open error.
So I made a simple test.c and ran the cross compiler on it:

arm-elf-gcc -save-temps -v test.c -o arm-elf-test

This results in the same error (see below).

If I run: /usr/local/arm-elf/bin/as.exe test.s

On the saved test.s file it assembles successfully.

It seems for some reason the file isn't being passed to the assembler, it's
just getting a blank argument list. Its the same when the files are created
in the TEMP directory or when -save-temps is specified.

I'm still beggin' for clues. Thanx for all the help!!!

John E. A.

---arm-elf-gcc error output---

$ arm-elf-gcc -save-temps -v test.c -o arm-elf-test
Reading specs from /usr/local/lib/gcc-lib/arm-elf/2.95.2/specs
gcc version 2.95.2 19991024 (release)
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/cpp.exe -lang-c -v -D__GNUC__=2
-D__GNUC_
MINOR__=95 -Darm -Darm_elf -D__ELF__ -D__arm__ -D__arm_elf__ -D__ELF__
-D__arm -
D__arm_elf -Acpu(arm) -Amachine(arm) -D__CHAR_UNSIGNED__ test.c test.i
GNU CPP version 2.95.2 19991024 (release) (ARM/ELF non-Linux)
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/include
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/../../../../arm-elf/include
End of search list.
The following default directories have been omitted from the search path:
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/../../../../include/g++-
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/../../../../arm-elf/sys-include
End of omitted list.
 /usr/local/lib/gcc-lib/arm-elf/2.95.2/cc1.exe test.i -quiet -dumpbase
test.c -v
ersion -o test.s
GNU C version 2.95.2 19991024 (release) (arm-elf) compiled by GNU C version
2.95
.2-6 19991024 (cygwin experimental).
 /usr/local/arm-elf/bin/as.exe
Assembler messages:
 for reading.open
: No such file or directory


------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list