arm-linux cross gcc build failure

John Andrews john@triscend.com
Thu Mar 15 11:51:00 GMT 2001


Hi Nhat,

Did your change to ARM_Hint for the #define within the arm.h file eliminate
the prefix.c compile error?

I switched a couple of days ago to trying to use the arm gcc executable
produced by the instructions provided by redhat for the eCos environment.

http://sources.redhat.com/ecos/tools/win-arm-elf.html

When following these instructions explicitly, I was able to produce the
cross-gcc  executable. However I've since learned that the produced compiler
does not generate PIC (position independent code) executables. So while it
might work for building an embedded linux kernel or an application that will
be loaded and executed without any os, it will not produce the code needed
for an application that will be loaded and executed by linux in the embedded
target.

My objective is to build uClinux for ARM7TDMI and I've had several people
tell me that I need to switch from Cygwin to a linux development host.

Are you trying to build an os environment or executables to will run
directly on the processor with no os?

Another excellent site is:

http://www.beyondlogic.org/

There are two pages for building the tools and kernel needed for uClinux.
It's written for 68k but the general info is very thorough and useful.

A classic ARM Linux site is:

http://www.tazenda.demon.co.uk/phil/armlinux/

Under the Tools section there is a link to his tool building instructions:

http://www.tazenda.demon.co.uk/phil/arm-tools.html

as well as a link to Chris Ritter's site, which is another very good ARM
tool info site.

http://inkvine.fluff.org/~chris/arm-tools.html

Another that I just discovered recently is:

http://www.xraylith.wisc.edu/~khan/software/gnu-win32/

Items 10, 11 and 14 in this list were helpful for me.

Let me know your latest status. Good Luck!

John E. A.

p.s. After assembling these links I thought I'd copy the list in the hope
that they might help others who are trying to build cross tools for ARM.

-----Original Message-----
From: nhat.dao@philips.com [ mailto:nhat.dao@philips.com ]
Sent: Thursday, March 15, 2001 5:24 AM
To: john@triscend.com
Subject: Re: arm-linux cross gcc build failure


hi John,

i have the same problem : [prefix.o] Error 2 when i do a make.
(see, in cygwin mailing list "cross compiler under Cygwin")

do you find a answer to your problem ?

/pegase

john@triscend.com a écrit :

> Hold the presses...
>
> I fat fingered the --prefix in the configure script.
>
> It still doesn't build, but it's out of cygwin land and squarely into the
> realm of crossgcc.
>
> Sorry for the spurious post...
>
> John E. A.
>
> -----Original Message-----
> From: John Andrews
> Sent: Friday, March 09, 2001 2:02 AM
> To: 'cygwin@cygwin.com'
> Subject: arm-linux cross gcc build failure
>
> Hi All,
>
> I'm having trouble building an arm-linux cross compiler under cygwin.
>
> I'd post this to the cross gcc list but I'm pretty sure my difficulty is
> specific to the cygwin environment.
>
> Below is the tail of the make output:
>
> --begin make out--
> gcc -DCROSS_COMPILE -DIN_GCC     -g  -DHAVE_CONFIG_H    -I.
> -I/usr/src/gcc-2.95.
> 2/gcc -I/usr/src/gcc-2.95.2/gcc/config
-I/usr/src/gcc-2.95.2/gcc/../include
> \
> -DPREFIX=\"/usr/uClinux\" \
>   -c `echo /usr/src/gcc-2.95.2/gcc/prefix.c | sed 's,^\./,,'`
> In file included from /usr/include/w32api/windef.h:143,
>                  from /usr/include/w32api/windows.h:96,
>                  from /usr/src/gcc-2.95.2/gcc/prefix.c:69:
> /usr/include/w32api/winnt.h:2266: two or more data types in declaration of
> `type
>  name'
> make: *** [prefix.o] Error 1
> --end make out--
>
> I blindly tried find . -type f -exec dos2unix \{\} \; in the include
> directory.
>
> I have binutils configured for arm-elf-linux, built and installed, and
used
> the following config for gcc:
>
> /usr/src/gcc-2.95.2/configure --target=arm-elf-linux \
> --prefix=/usr/uClinux \
> --exec-prefix=/usr/arm-uClinux/H-i686-pc-cygwin/arm-uClinux/bin \
> --with-gnu-as --with-gnu-ld --with-newlib \
> -v 2>&1 | tee configure.out
>
> Any help would really be appreciated!
>
> Thanks...
>
> John E. A.
>
> --
> Want to unsubscribe from this list?
> Check out: http://cygwin.com/ml/#unsubscribe-simple


------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list