crossgcc

Rich Leggitt rich.leggitt@setengineering.com
Wed Mar 14 15:18:00 GMT 2001


Hi all, I'm trying to set up mips C crossgcc for linux i686 per the crossgcc
faq.

First I tried "./configure --target=mips_elf --prefix=adirectory ; make all"
which eventually yielded message "can't exec mips-tfile", this has been
well-documented in the crossgcc archive. 

Then I added the recommended "--with-gnu-as" results in "mips-elf-ar:
command not found", the file does exist but is apparently invoked without
prefix adirectory/bin/. 

After bunches of retries with various options and source trees, I gave up on
the manual process and tried 
"one-tree-1.6.sh ; build-cross.sh mips-elf", but this quickly chokes trying
to compile ../../src/bfd/archive.c due to missing includes fopen-same.h,
aout/ar.h, aout.ranlib.h. These files exist, I believe the -I paths on the
invocation are missing.

As a sanity check, I also tried "build-cross powerpc-eabi" as referenced in
the faq, this failed in exactly the same way.

The REAL problem of course is that I don't understand the process, but I
also don't really have the time to figure it out.  

Does anybody know what's wrong? TIA == Rich

------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com



More information about the crossgcc mailing list