GCC on windows for 68k

Tawde, Ganesh gtawde@opentv.com
Thu Jun 21 19:08:00 GMT 2001

Title: GCC on windows for 68k

followed the procedure you told me. Let me explain you my environment (since I 
am the first time user of GNU tools and not worked much on Unix platform, some 
things may sound stupid, please bear with me ) . I downloaded the latest Cygwin 
1.3.2 and installed it on my PC with Windows NT 4.0. I got 
gcc3.0(gcc-core-3.0.tar.gz) ,  binutils 2.11(binutils-2.11.tar.gz), newlib 
1.9.0 (newlib-1.9.0.tar.gz). Then I tried to go through the crossgcc faq. But I 
found another document at http://sources.redhat.com/ml/crossgcc/2000-q2/msg00195.html . 
I found it more descriptive and understanding so I followed the steps mentioned 
in there. Only I am using different versions of the packages and different 
target than mentioned in the doc ( m68k-coff instead of m68k-elf) . I followed 
everything step by step compiling the packages in the Cygwin bash shell on my 
PC. I could successfully make binutils and gcc. But when making newlib, I faced 
some internal compiler error. I am not sure as to what it is and how to get rid 
of it. Here is the error I got.
-B/home/gtawde/m68knewlib/m68k-coff/newlib/ -isystem 
/home/gtawde/ m68knewlib/m68k-coff/newlib/targ-include -isystem 
/home/gtawde/newlib-1.9.0/newlib/libc/include -DPACKAGE=\"newlib\" 
-DVERSION=\"1.9.0\"  -I. 
-I../../../../../newlib-1.9.0/newlib/libc/stdlib  -O2 
-I../../targ-include  -I../../../../../newlib-1.9.0/newlib/libc/../libc/include 
-fno-builtin      -g -O2 -c 
../../../../../newlib-1.9.0/newlib/libc/stdlib/dtoa.c ../../../../../newlib-1.9.0/newlib/libc/stdlib/dtoa.c: 
In function 
`_dtoa_r': ../../../../../newlib-1.9.0/newlib/libc/stdlib/dtoa.c:853: 
Internal compiler error in update_equiv_regs, at local-alloc.c:1097 Please 
submit a full bug report, with preprocessed source if appropriate. See 
< URL:http://www.gnu.org/software/gcc/bugs.html > 
for instructions. make[3]: *** [dtoa.o] Error 1 make[3]: Leaving directory 
`/home/gtawde/m68knewlib/m68k-coff/newlib/libc/stdlib ' make[2]: *** 
[all-recursive] Error 1 make[2]: Leaving directory 
`/home/gtawde/m68knewlib/m68k-coff/newlib/libc' make[1]: *** [all-recursive] 
Error 1 make[1]: Leaving directory 
`/home/gtawde/m68knewlib/m68k-coff/newlib' make: *** [all-target-newlib] 
Error 2
I also 
tried using newlib 1.8.2 but still I was getting errors ( i lost the error log 
anybody help me in this?

  -----Original Message----- From: Vermeulen Jan 
  [mailto:Jan.Vermeulen@siemens.atea.be] Sent: Wednesday, June 20, 
  2001 11:30 PM To: 'CrossGCC' Subject: GCC on windows for 
  Hello Ganesh.... 
  First you got to download & install cygwin 
  at http://sources.redhat.com/cygwin/ 
  Then you procede by taking a look at http://crossgcc.billgatliff.com/ for 
  his wonderful building script. (m68k-coff is what your 
  target will be) 
  By the way, if you extract the source-code from 
  the '*.tar.gz' with WinZip (or the likes), make 
  sure winzip doesn't change the <LF> to 
  <CR><LF>. (go to the 
  options->configuration->miscellaneous and make 
  sure the 'TAR file smart CR/LF conversion' is *not* 
  It's better you extract it with "tar xfz 
  <file>.tar.gz" under cygwin. 
  Then you can start adjusting your Visual Studio so it 
  can compile with the m68k-coff-g++ or m68k-coff-gcc. 
  Good luck, i hope this is helpful. Jan 
  -----Original Message----- From: 
  Tawde, Ganesh [ mailto:gtawde@opentv.com ] Sent: dinsdag 19 juni 2001 20:44 To: 
  'crossgcc@sourceware.cygnus.com' Subject: GCC on 
  windows for 68k 
  Hi,  I am looking for a GCC cross 
  compiler on Windows for 68331 processor. I want the 
  compiler to use on a Windows NT machine and which will cross compile for the 68331 processor. Can anybody 
  give me some links and some more information on how I can proceed ? Thanks in advance. Ganesh 

More information about the crossgcc mailing list