m68k cygwin on NT (again)

Vermeulen Jan Jan.Vermeulen@siemens.atea.be
Fri Jun 1 01:56:00 GMT 2001

Dear sir, madam,

I have been able to succesfully make a m68k-coff crosscompiler on
a linux box by using the 'kind of cross compiling howto'

Now i am trying to do the same for cygwin on a windows NT 
Cygwin works fine, but when i try to make m68k-coff-gcc, it all
goes wrong.

what i have :

(~/src/)$ cd m68kbintutils
(~/src/m68kbinutils)$ ../binutils-2.10.1/configure --target=m68k-coff
(~/src/m68kbinutils)$ make all install

this goes ok. Then I set up the symlink in the /usr/local/m68k-coff
('include' to point to newlib's include) (as explained in the 'kind of cross
compiling howto')

After that, i go on with GCC itself :

(~/src/m68kbinutils)$ cd ../m68kgcc
(~/src/m68kgcc)$ ../gcc-2.95.3/configure --target=m68k-coff
(~/src/m68kgcc)$ make

and it produces this output:
make[1]: Leaving directory `/home/Administrator/src/m68kgcc/etc'
make[1]: Entering directory `/home/Administrator/src/m68kgcc/gcc'
(cd intl && make all)
make[2]: Entering directory `/home/Administrator/src/m68kgcc/gcc/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/Administrator/src/m68kgcc/gcc/intl'
./genattr ../../gcc-2.95.3/gcc/config/m68k/m68k.md > tmp-attr.h
.  At file position: 139ound character
Following characters are:

;; This file is part of GNU CC.

;; GNU CC is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
;; the Free Software FouAborting.
genattr: Internal compiler error in `dump_and_abort', at
Please submit a full bug report.
See <URL: http://www.gnu.org/software/gcc/bugs.html > for instructions.
make[1]: *** [s-attr] Error 33
make[1]: Leaving directory `/home/Administrator/src/m68kgcc/gcc'
make: *** [all-gcc] Error 2

Administrator@PCF794 ~/src/m68kgcc

First, i redid the whole process again to make 
sure i didn't screw up somewhere myself.

Then, i searched the mailing-list archives and tried out some things :
(every time, i removed the m68kgcc directory and mkdir'ed it again)
1) configure --target=m68k-coff --enable-languages=c,c++ --with-newlib
--with-included-gettext --with-gnu-as --with-gnu-ld
2) the same, but first do a "mv -i texinfo old.texinfo" in the gcc-source

Same error everytime.
I'm kind of lost of what to do next.

Can anybody help ?
Thanks a lot!

Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com

More information about the crossgcc mailing list