Cross system in DJGPP problems

Pollak Leon leonp@plris.com
Thu Jul 15 00:55:00 GMT 1999


A lot of excuses for sending this message possibly twice, but I don't see
my first postings (not for the first time) on the list!?
----------------------------------------------------------------------------
----------------------------------------------------------------
Hello, all,
	I am trying to use binaries for cross DJGPP-PPC development from
S.Howard's www.objsw.com site and I have the following problems:
	1. "Native" gcc compiler in the host DJGPP environment from S.Howard
xgcc.zip file didn't want to work, telling all the time "gcc.exe:
installation problem, cannot exec `cpp': No such file or directory". I
solved this problem by simply installing original DJGPP files from the
corresponding site. I did this in the hope that when native gcc will work,
everything else will work too.
	My hopes didn't come to reality - now I can compile native programs, but
still, execution ppc-gxx.exe causes the same error message to appear.
2. All this I do in order to try to build some packages and the first will
be the newlib library. I wasn't able to find port of "sh" shell, without
which it is rather difficult to run configure scripts - each of them
contains "#! /bin/sh" line. May I simply make alink (o copy) to bash.exe or
there are significant differences between bash and sh?
3. I did the substitution of sh to bash in some of scripts and it looks
like working. But the main script fails on the "mv" command with the
following error message:
	C:/DJGPP/BIN/mv: cannot move `./Makefile.tem2' to `./Makefile.tem':
Permission denied (EACCES)

	Any comments or help on these problems will be highly appresiated.



Leon Pollak
leonp@plris.com
_______________________________________________
New CrossGCC FAQ: http://www.objsw.com/CrossGCC
_______________________________________________
To remove yourself from the crossgcc list, send
mail to crossgcc-request@cygnus.com with the
text 'unsubscribe' (without the quotes) in the
body of the message.


More information about the crossgcc mailing list