Wanted! Patch to gcc-2.8.1 for target ARM Thumb

Kai Ruottu karuottu@freenet.hut.fi
Thu Jul 8 08:52:00 GMT 1999


> Does anyone have any patch for the gcc-2.8.1 which support the target
> "thumb-coff"?

 Using some more up-to-date sources like egcs-1.1.2 or gcc-2.95 prerelease,
(the latest egcs snapshots) is higly recommended... The ARM-support in 2.8.1 is 
old and buggy...

      www.sourceware.cygnus.com/egcs
 
> It works fine to configure and install the binutils-2.9.1 for the target
> "thumb-coff", but

 Using the binutils snapshots for ARM-targets may also be motivated...

> when I tried to configure and install the C compiler (gcc), the configure
> command don't know how to build the target. However, IT IS possible to "make"! But
> "make" ends up complaining that "libgcc1.a" is missing.

 I would expect gcc-2.8.1 to NOT work for 'thumb-coff' at all.... Using the 
current egcs-GCC-release should work Ok :

  E:\usr\local\samples\sort>gcc-thumb-coff -v
  Reading specs from E:/usr/local/lib/gcc-lib/thumb-coff/egcs-1.12/specs
  gcc version egcs-2.91.66 19990314 (egcs-1.1.2 release)

 Cheers, Kai
_______________________________________________
New CrossGCC FAQ: http://www.objsw.com/CrossGCC
_______________________________________________
To remove yourself from the crossgcc list, send
mail to crossgcc-request@cygnus.com with the
text 'unsubscribe' (without the quotes) in the
body of the message.


More information about the crossgcc mailing list