Bulding a virgin egcs cross-compiler

John Breen jab3@hotmail.com
Fri Sep 25 11:46:00 GMT 1998

I'm having so much trouble, I decided to add the crossgcc list to this, 
since some of the people on there might be using egcs but don't get the 
egcs list.

Last winter, I built a gcc- based cross compiler with newlib for 
m68k-elf under Linux.  Other than having to get patches to allow elf 
with m68k, it all went fairly smoothly (I used the separate-tree 
process, not the single-tree).

Now I'm trying to build an egcs-1.1a based cross compiler for the same 
target, under HPUX-10.20.  The headers for m68k-elf are somewhat 
experimental, but everything else is stock.  I've run into a few 

First, egcs requires certain system headers during the build.  I copied 
those over from newlib, but it strikes me odd that egcs needed them when 
gcc-2.7.x didn't.

Then, when it got to libf2c (which I don't even want, but can't figure 
out how to get rid of), it decided that it needed crt0.o.  It was 
suggested that I change to the "one tree" build.  Since I had binutils 
built already, I just linked in the parts of newlib as shown in the 
crossgcc FAQ.  This seemed to work as far as building newlib (and 
finding headers), but it still failed for lack of crt0.o.

At this point, I punted and copied over the rtems crt0.c (which looks 
like just a dummy).  Then it failed somewhere down in libf2c because it 
couldn't find autoconf.  I tried renaming the libf2c source directory, 
to see if it would just skip it.  It didn't.  I tried running configure 
again and rebuilding.  It appears to be rebuilding the whole thing from 
scratch, which will probably take the rest of the afternoon.

Has anyone else had this much trouble?  One person suggested privately 
that the compiler is probably built; but until I figure out how to get 
past libf2c, I won't know how much further the build process really has 
to go.
John A. Breen

Get Your Private, Free Email at http://www.hotmail.com

More information about the crossgcc mailing list