problem building binutils host=linux target=m68k-coff

Robert J. Brown rj@eli.elilabs.com
Wed Feb 4 15:20:00 GMT 1998


>>>>> "Robert" == Robert J Brown <rj@eli.elilabs.com> writes:

    Robert> I ftp-ed the binutils-2.7.tar.gz from prep.ai.mit.edu, and
    Robert> binutils-2.6-obj-coff.patch from ftp.cygnus.com, unpacked
    Robert> the tar and applied the patches as directed by the FAQ
    Robert> from /ftp.cygnus.com:/pub/embedded/crossgcc, and did the
    Robert> make all.  This worked fine, but when I did the make
    Robert> install, I got the following:

    Robert>     make[2]: Entering directory
    Robert> `/away/zen/gnu/build-binutils/libiberty' make[2]: Leaving
    Robert> directory `/away/zen/gnu/build-binutils/libiberty'
    Robert> /away/zen/gnu/binutils-2.7/install.sh -c -m 644
    Robert> libiberty.a m68k/lib/libiberty.a.n ( cd m68k/lib ; ranlib
    Robert> m68k/lib/libiberty.a.n ) ranlib: m68k/lib/libiberty.a.n:
    Robert> No such file or directory make[1]: *** [install_to_libdir]
    Robert> Error 9 make[1]: Leaving directory
    Robert> `/away/zen/gnu/build-binutils/libiberty' make: ***
    Robert> [install-libiberty] Error 2

    Robert> The cd on the 4th line looks like it is trying to cd to
    Robert> the m68k/lib directory, but then tries to run ranlib on
    Robert> m68k/lib/libiberty.a.n, when it looks to me like it should
    Robert> have been just libiberty.a.n, since it already did the cd
    Robert> m68k/lib.

    Robert> Am I just dense, or is the make install scrogged?

Not to reply to my own post or anything, but after I sent the first
email, I realized that I should not have applied the patch, since I
was using 2.7 and the patch was for 2.6; *DUH*!!!  I am dense!

Oh well, I blew the binutils-2.6 directory away and re-unpacked the
tar and tried again, this time without the patch.  It worked!  Sorry
to bother the list...

    Robert> Also, the FAQ seems to refer to versions older than
    Robert> current for the gnu tolls binutils and gcc.  Should I be
    Robert> using the latest versions, or is there a real reason to
    Robert> stay with the older ones?

I am still curious about this issue.  Any answers?

-- 
--------  "And there came a writing to him from Elijah"  [2Ch 21:12]  --------
Robert Jay Brown III rj@eli.elilabs.com  http://www.elilabs.com 1 847 705-0424
Elijah Laboratories Inc.;  37 South Greenwood Avenue;  Palatine, IL 60067-6328
-----  M o d e l i n g   t h e   M e t h o d s   o f   t h e   M i n d  ------



More information about the crossgcc mailing list