BSD to Hitachi sh-hms cross compiler problems.

Bernie Doehner bad@uhf.wireless.net
Fri Jun 20 10:44:00 GMT 1997


> > uhf:~/sh/link> make link.x
> > /usr/local/sh/bin/sh-hms-ld link.o -Tlink.lnk -o link.x
> > link.o(.text+0x3a4):link.c: undefined reference to `___sdivsi3'
> > *** Error code 1
> 
> 

Hi Jason:

Dr. Rulnick is my advisor, so I am Cc:'ing him so he knows I am getting
help on this problem.
 
> It's usually better to just run the linker via gcc.  gcc is just
> a front-end that runs the c preprocessor, the c compiler, the assembler
> and then the linker.  

Ok, I tried that, at least divide works now - thanks.

Only problem is that gcc doesn't read the linker script so it outputs in
coff format. My current application requires srecord format so that I can
upload with a Unix clone of hint. (uploading with gdb causes the serial
port to become unuseable).

Is there any way to make gcc output in srec format?   

> Specifically, the problem is that you need to link in libgcc.a where
> this function is supplied.
> 

And if that doesn't work, how would I lin,k to libgcc.a?  I tried -lgcc as
a linker argument (in the original makefile) and it couldn't find it.

Thanks for your help.

Bernie




More information about the crossgcc mailing list