The cgen_insn_type enumeration in @arch@-opc.h suffers from the fact that the final enumerator is called @ARCH@_INSN_MAX. This makes it impossible to name an instruction `max'. Any objections if the internal value is given the name @ARCH@_INSN__MAX or similar? Yes, the instruction could be given a different name but we should avoid limiting the input language in this way. Ben