[PATCH v6 1/4] Adjust pdata function table entries sorting for AArch64

Evgeny Karpov evgeny.karpov@arm.com
Wed Mar 18 13:27:53 GMT 2026


On Fri, Mar 13, 2026, Alice Carlotti wrote:
> > +	    /* .pdata entries should be sorted by the function start
> > +	       address.  */
> >  	    qsort (tmp_data,
> > -		   (size_t) (x / 12),
> > -		   12, sort_x64_pdata);
> > +		   (size_t) (x / function_table_entry_size),
> > +		   function_table_entry_size, sort_x64_pdata);
> 
> I think sort_x64_pdata should be renamed to sort_pdata, but this otherwise
> looks fine to me.

sort_x64_pdata will be renamed to sort_pdata.

Regards,
Evgeny



More information about the Binutils mailing list