[PATCH] x86: separate AVX10.1-aux from AVX10.2

Jiang, Haochen haochen.jiang@intel.com
Mon Jul 13 08:50:00 GMT 2026


> From: Jan Beulich <jbeulich@suse.com>
> Sent: Monday, July 13, 2026 2:30 PM
> 
> On 13.07.2026 04:20, Jiang, Haochen wrote:
> >> From: Jan Beulich <jbeulich@suse.com>
> >> Sent: Friday, July 10, 2026 8:23 PM
> >>
> >> --- a/gas/config/tc-i386.c
> >> +++ b/gas/config/tc-i386.c
> >> @@ -1247,13 +1247,14 @@ static const arch_entry cpu_arch[] =
> >>    VECARCH (sm4, SM4, ANY_SM4, reset),
> >>    SUBARCH (pbndkb, PBNDKB, PBNDKB, false),
> >>    VECARCH (avx10.1, AVX10_1, ANY_AVX512F, set),
> >> +  VECARCH (avx10.1aux, AVX10_1_AUX, ANY_AVX10_1_AUX, set),
> >
> > Maybe avx10_v1_aux instead of avx10.1aux to align with documentation?
> 
> I was wondering, but imo the existing "avx10.1" makes it pretty clear cut.
> I would have wanted to make it "avx10.1-aux", but dashes aren't okay to use
> here, and "avx10.1_aux" feels somewhat odd.

If we do not want to use v1, then the current name is definitely a win.

This is an AMD proposed feature bit actually, while Intel will emulate that bit
to avoid break on HW. So, let's wait AMD folks to share their opinion on option
names. We also need to make sure that it is the same naming convention as
AVX10_V2_AUX.

Thx,
Haochen


More information about the Binutils mailing list