[PATCH,V2 0/5] sframe: use data word instead of offset

Indu Bhagat indu.bhagat@oracle.com
Fri Jan 23 10:35:56 GMT 2026


Hi,

This version is rebased on latest master and addresses Jens' reviews.

V1 posting: https://inbox.sourceware.org/binutils/20260120102824.2522876-1-indu.bhagat@oracle.com/

I will take one more look at these before committing.

Thanks,

Indu Bhagat (5):
  sframe: doc: terminology change from offset to data word
  include: gas: sframe: fix terminology from offset to data word
  libsframe: rename offset in user-facing sframe_frame_row_entry struct
  libsframe: rename flip_fre_stack_offsets to flip_fre_datawords
  libsframe: rename sframe_fre_* internal APIs to use data word instead
    of offset

 gas/gen-sframe.c               | 263 ++++++++++++++++-----------------
 include/sframe-api.h           |   8 +-
 include/sframe.h               |  29 +++-
 libsframe/doc/sframe-spec.texi | 162 +++++++++++---------
 libsframe/sframe.c             | 155 +++++++++----------
 5 files changed, 328 insertions(+), 289 deletions(-)

-- 
2.43.0



More information about the Binutils mailing list