[PATCH 0/5] sframe: use data word instead of offset
Indu Bhagat
indu.bhagat@oracle.com
Tue Jan 20 10:28:19 GMT 2026
Hi,
During the review cycle of SFrame V3, renaming of SFrame FRE offsets to
something more appropriate was suggested. In this patch series, we
adopt the term 'data word' in place of 'offset'.
In general, in SFrame stack trace format, the interpretation of the
variable-length array of bytes is deteremined by the FDE type and
ABI/arch. With the introduction of SFrame V3, and the new FDE type
SFRAME_FDE_TYPE_FLEX, it is better to move away from using the term
"stack offsets" to something more generic like "data words". The use of
the "word" here is colloquial, and the size of data words continues to
be determined by the bits in the SFrame FRE info.
More info in each individual commit. Please take a look and let me know
what you think of the terminology change.
No changes to ld/ and libsframe/testsuite/ are done yet. My intention
with this patch series is to rename in the user-interfacing components
(specification, header file, which later necessitated changes to
libsframe too).
The patches are available in branch
users/ibhagat/sframe-v3-dataword-rename-m1 in case it helps in
reviewing.
Thanks,
Indu Bhagat (5):
sframe: doc: terminology change from offset to data word
include: gas: sframe: fix terminology from offset to data word
libsframe: rename offset in user-facing sframe_frame_row_entry struct
libsframe: rename flip_fre_stack_offsets to flip_fre_datawords
libsframe: rename sframe_fre_* internal APIs to use data word instead
of offset
gas/gen-sframe.c | 263 ++++++++++++++++-----------------
include/sframe-api.h | 8 +-
include/sframe.h | 29 +++-
libsframe/doc/sframe-spec.texi | 140 ++++++++++--------
libsframe/sframe.c | 151 +++++++++----------
5 files changed, 313 insertions(+), 278 deletions(-)
--
2.43.0
More information about the Binutils
mailing list