[PATCH 3/3] include/aout/aout64.h: guard ARCH_SIZE with defined()
Andrew Hanson
andrew@andrewhanson.dev
Mon Sep 15 14:59:39 GMT 2025
> Okay, so let's go with what you had sent.
That sounds good, thanks.
I did do a bit of digging regarding that else block. Atleast these four files (bfd/aout-ns32k.c, bfd/aout-target.h, bfd/aoutx.h, bfd/ecoff.c) include aout/aout64.h and use the 32 magic numbers (OMAGIC 0407, NMAGIC 0410, IMAGIC 0411, ZMAGIC 0413, QMAGIC 0314, BMAGIC 0415) without checking ARCH_SIZE, so they likely depend on the current behavior. Just FYI.
On Monday, September 15th, 2025 at 10:21 AM, Jan Beulich <jbeulich@suse.com> wrote:
> On 15.09.2025 06:26, Andrew Hanson wrote:
>
> > Sorry about the missing sign-offs on the first two patches. I'm still getting used to the tooling.
>
>
> Btw, please also don't reply privately; keep the list in Cc.
>
> > I agree the question about if the else block should trigger or not is complicated. I would be tempted to just keep the previous behavior regarding the else statement because I don't know enough about the project to know the downstream effects.
> >
> > It would almost certainly be worth adding a warning for the user if ARCH_SIZE is undefined. It might also make sense to discuss deprecating the “undefined -> 32-bit” fallback but I don’t feel comfortable making that call.
>
>
> Okay, so let's go with what you had sent.
>
> Jan
More information about the Binutils
mailing list