[PATCH v6 1/5] Add suitable defines to use at call and use sites
Guillaume VACHERIAS - foss
guillaume.vacherias@foss.st.com
Fri Nov 21 14:01:04 GMT 2025
> On 21.11.2025 13:51, Guillaume VACHERIAS wrote:
> > Fuse do_loc and do_types arguments into a signle unsigned int do_flags for
> > better code readability.
> >
> > binutils/
> >
> > * dwarf.c (DO_LOC, DO_TYPES): Define.
> > (process_debug_info): Change arguments do_loc and do_types
> > to a single unsigned int do_flags.
> > (find_cu_tu_set_v2): Change parameter do_types from int to bool.
> > ---
> > binutils/dwarf.c | 75 +++++++++++++++++++++++++++---------------------
> > 1 file changed, 43 insertions(+), 32 deletions(-)
>
> Btw, I was meaning to have this one put in already, but with there being no
> S-o-b
> I fired off an inquiry as to you having a copyright assignment in place. Sadly I
> didn't get any feedback there yet, so maybe you could clarify your status to
> me?
Sorry, I've simply forgotten to add the Signed-off, I'll resubmit this patch alone.
Guillaume
More information about the Binutils
mailing list