[PATCH,V2 0/4] libsframe: minor cleanup patches

Indu Bhagat indu.bhagat@oracle.com
Mon Nov 10 08:54:21 GMT 2025


On 11/5/25 6:55 AM, Jens Remus wrote:
> Hello Indu!
> 
> On 11/5/2025 9:57 AM, Indu Bhagat via Binutils wrote:
>> This patchset makes some minor cleanups to libsframe code, before moving
>> forward with V3 patches.  Details in the commit log of each patch.
> 
> Thank you!
> 

Thanks I have committed the two patches for now:

b91966e2df7 libsframe: rename encoder to ectx for readability
b263aca0a5f libsframe: fix checks in flip_fde


>>    libsframe: remove old sframe_decoder_get_funcdesc API
>>    libsframe: remove old sframe_encoder_add_funcdesc, make it internal
> The code changes LGTM.  But I am unfamiliar when it is appropriate to
> remove functions from a library API.
> 

Yeah, I was also thinking about this.

Previously, we have followed the following scheme:
   - Mark an API for removal. E.g, we had marked other V1 API 
(sframe_get_funcdesc_with_addr) for removal in X+2 release.
   - Removed the API with version bump, closer to the release date of 
binutils.

I think I should stick to following the above (marking for removal wasnt 
done, but I think these APIs are close cousins to the already removed 
sframe_get_funcdesc_with_addr, so it should be OK).  I will keep these 
patches in the work queue for now.  And send a patch closer to date when 
the version is bumped.

(That said, libsframe's use is for BFD ld.)

Thanks,


More information about the Binutils mailing list