[PATCH,V2 0/4] libsframe: minor cleanup patches

Indu Bhagat indu.bhagat@oracle.com
Wed Nov 5 08:57:56 GMT 2025


This patchset makes some minor cleanups to libsframe code, before moving
forward with V3 patches.  Details in the commit log of each patch.

Addressed review comments by Jens.

Thanks,
Indu Bhagat (4):
  libsframe: fix checks in flip_fde
  libsframe: remove old sframe_decoder_get_funcdesc API
  libsframe: remove old sframe_encoder_add_funcdesc, make it internal
  libsframe: rename encoder to ectx for readability

 include/sframe-api.h    |  70 ++++------
 libsframe/libsframe.ver |   2 -
 libsframe/sframe.c      | 275 ++++++++++++++++++----------------------
 3 files changed, 149 insertions(+), 198 deletions(-)

-- 
2.43.0



More information about the Binutils mailing list