[PATCH] ld: rename ldirname to stat_ldirname

Andreas Schwab schwab@suse.de
Wed May 14 15:13:42 GMT 2025


It conflicts with the ldirname function in libiberty.

ld/:
	* ldlang.c (stat_ldirname): Rename from ldirname, all uses
	changed.
---
 ld/ldlang.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/ld/ldlang.c b/ld/ldlang.c
index e0368171fa9..32e6e7abdf1 100644
--- a/ld/ldlang.c
+++ b/ld/ldlang.c
@@ -322,7 +322,7 @@ spec_match (const struct wildcard_spec *spec, const char *name)
 }
 
 static char *
-ldirname (const char *name)
+stat_ldirname (const char *name)
 {
   const char *base = lbasename (name);
 
@@ -1266,7 +1266,7 @@ new_afile (const char *name,
       /* If name is a relative path, search the directory of the current linker
 	 script first. */
       if (from_filename && !IS_ABSOLUTE_PATH (name))
-	p->extra_search_path = ldirname (from_filename);
+	p->extra_search_path = stat_ldirname (from_filename);
       p->flags.real = true;
       p->flags.search_dirs = true;
       break;
-- 
2.49.0


-- 
Andreas Schwab, SUSE Labs, schwab@suse.de
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."


More information about the Binutils mailing list