[PATCH] Fix typo: "/usrlib64/debug/usr" should be "/usr/lib64/debug/usr/"
Sam James
sam@gentoo.org
Mon Jun 30 00:11:47 GMT 2025
Vladimir Mezentsev via Binutils <binutils@sourceware.org> writes:
> From: Vladimir Mezentsev <vladimir.mezentsev@oracle.com>
With a ChangeLog added and perhaps a PR tag added for the bug which
added it, it looks obviously right and could go in as such.
>
> ---
> binutils/dwarf.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/binutils/dwarf.c b/binutils/dwarf.c
> index 5b3ece58c8b..b301a3a4a7e 100644
> --- a/binutils/dwarf.c
> +++ b/binutils/dwarf.c
> @@ -12330,7 +12330,7 @@ load_build_id_debug_file (const char * main_filename ATTRIBUTE_UNUSED, void * ma
> + strlen (".debug")
> /* The next string should be the same as the longest
> name found in the prefixes[] array below. */
> - + strlen ("/usrlib64/debug/usr")
> + + strlen ("/usr/lib64/debug/usr/")
> + 1);
> void * handle;
>
> @@ -12341,7 +12341,7 @@ load_build_id_debug_file (const char * main_filename ATTRIBUTE_UNUSED, void * ma
> "/usr/lib/debug/",
> "/usr/lib/debug/usr/",
> "/usr/lib64/debug/",
> - "/usr/lib64/debug/usr"
> + "/usr/lib64/debug/usr/"
> };
> long unsigned int i;
More information about the Binutils
mailing list