[committed v2 2/4] aarch64: Fix operand name MOPS_WB_Rd -> MOPS_WB_Rn
Richard Earnshaw
rearnsha@arm.com
Mon Jul 21 17:19:54 GMT 2025
This field was misnamed in aarch64_opcode_table. It previously didn't
matter too much as the name field only appeared in dumps. But it
doesn't match the enum in include/opcode/aarch64.h and we will shortly
start to rely on that.
---
opcodes/aarch64-tbl.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/opcodes/aarch64-tbl.h b/opcodes/aarch64-tbl.h
index b23fc7c6bc5..0ae7342e2e1 100644
--- a/opcodes/aarch64-tbl.h
+++ b/opcodes/aarch64-tbl.h
@@ -8199,7 +8199,7 @@ const struct aarch64_opcode aarch64_opcode_table[] =
"a register destination address with writeback") \
Y(INT_REG, x0_to_x30, "MOPS_ADDR_Rs", 0, F(FLD_Rs), \
"a register source address with writeback") \
- Y(INT_REG, x0_to_x30, "MOPS_WB_Rd", 0, F(FLD_Rn), \
+ Y(INT_REG, x0_to_x30, "MOPS_WB_Rn", 0, F(FLD_Rn), \
"an integer register with writeback") \
Y(IMMEDIATE, imm, "CSSC_SIMM8", OPD_F_SEXT, F(FLD_CSSC_imm8), \
"an 8-bit signed immediate") \
--
2.43.0
More information about the Binutils
mailing list