[PATCH v2 32/65] MMIX: use is_whitespace()

Hans-Peter Nilsson hp@bitrange.com
Fri Jan 31 06:18:19 GMT 2025


On Mon, 27 Jan 2025, Jan Beulich wrote:
> Convert open-coded checks as well as ISSPACE() uses. At the same time
> use is_end_of_stmt() instead of open-coded checks; do the conversion
> even when not adjacent to code being modified anyway to cover all cases
> where the is_end_of_line[] index was wrongly cast from plain char (which
> can be signed) to unsigned int.

Sorry, it looks like I'm going to have to finish looking at this 
late in week-end.

brgds, H-P


More information about the Binutils mailing list