[PATCH v2 32/65] MMIX: use is_whitespace()

Hans-Peter Nilsson hp@bitrange.com
Mon Feb 3 06:54:51 GMT 2025


On Mon, 27 Jan 2025, Jan Beulich wrote:
> Convert open-coded checks as well as ISSPACE() uses. At the same time
> use is_end_of_stmt() instead of open-coded checks; do the conversion
> even when not adjacent to code being modified anyway to cover all cases
> where the is_end_of_line[] index was wrongly cast from plain char (which
> can be signed) to unsigned int.
> ---
> v2: New.
> 
> --- a/gas/config/tc-mmix.c
> +++ b/gas/config/tc-mmix.c

Sorry, there are a few hunks that are wrong, like missing a test 
for ';' and other changes that may work but doesn't logically 
make sense to me.

Most of the stuff like s/ISSPACE/is_whitespace/ is obviously ok, 
as is of course fixing those horrible (unsigned int) typos.

I plan to post a replacement patch (5 hunks differ), but I need 
to look at it again with fresh eyes so I'll pause it for a day 
or two.

brgds, H-P


More information about the Binutils mailing list