[PATCH v3 33/44] gdb, dwarf, ze: add DW_OP_INTEL_regval_bits
Metzger, Markus T
markus.t.metzger@intel.com
Fri Aug 8 05:25:03 GMT 2025
Hello Jan,
Thanks for your review.
>>>> + The DW_OP_regval_bits operation extracts a value from a register. */
>>>> +DW_OP (DW_OP_INTEL_regval_bits, 0xfe)
>>>
>>> You're adding this to the GNU extensions space, which doesn't seem right,
>>> in particular given the name.
>>
>> What would be the correct way of adding an extension? It is, as far as I
>know,
>> only generated by the Intel Graphics Compilers, so we put INTEL in the
>name.
>>
>> Are you asking to rename it to GNU?
>
>Possibly. Not sure where the DW_OP_GNU_* namespace is maintained (and
>entries
>assigned), though.
In the vicinity, I see all kinds of different prefixes. Right above this one, for
example, we have DW_OP_AARCH64, DW_OP_PGI, DW_OP_HP, and then
DW_OP_GNU.
The numbers are all in the DWARF extension space, but I cannot see any pattern
as to how that gets further partitioned by GDB. I picked numbers that were still
available in the DWARF space and not used by any other extension in that file.
Jakub, Pedro, can you maybe help here?
>> Or are there separate extension spaces
>> per producer and we should declare it somewhere else?
>
>In principle the extensions are per "environment" aiui, which may or may not
>be "producer".
>
>Recently the DW_CFA_* handling was adjusted to cope with conflicting
>extensions.
>Likely the same is needed here. Especially if the value chosen is at risk of
>conflicting with something else down the road.
There are no conflicts currently.
Regards,
Markus.
Intel Deutschland GmbH
Registered Address: Am Campeon 10, 85579 Neubiberg, Germany
Tel: +49 89 99 8853-0, www.intel.de
Managing Directors: Sean Fennelly, Jeffrey Schneiderman, Tiffany Doon Silva
Chairperson of the Supervisory Board: Nicole Lau
Registered Office: Munich
Commercial Register: Amtsgericht Muenchen HRB 186928
More information about the Binutils
mailing list