[PATCH v1] x86: Support ZHAOXIN GMI instructions
mayshao-oc
mayshao-oc@zhaoxin.com
Tue Oct 15 01:31:11 GMT 2024
Hi Jan:
On 10/14/24 14:54, Jan Beulich wrote:
>
>
>
> On 14.10.2024 04:03, mayshao-oc wrote:
>> This patch adds support for Zhaoxin GMI instructions.
>> The documentation is attached for your reference.
>> Test ok, ok for trunk?
>
> In the NEWS entry, please add "x86" one way or another. Not everyone may
> know that Zhaoxin is an x86 flavor. Also the entry needs to move up, into
> the post-2.43 section.
>
Thanks for your comment, I fix it in the GMI v2 patch.
> For the i386-gen change I wonder whether GMI is an entirely separate
> extension, or kind of an extension to PadLock. Can you clarify the
> relationship please?
GMI is an entirely separate extension. GMI includes sm2, sm3, sm4
algorithms, and padlock includes RNG, AES, SHA, RSA algorithms, so they
are different.
>
> In i386-dis.c, if - following earlier comments - you still need some fixup
> function(s), please name them suitably. The pre-existing OP_0f07() is
> grossly misnamed, and that misnaming shouldn't be further extendedI will take care of the function name next time, and thanks for your
comment. From the comments and code, I learned something about
programming. I name the fixup function MONTMUL_Fixup in the GMI v2
patch, maybe there is a better idea?
> Jan
BR
Mayshao
More information about the Binutils
mailing list