[PATCH v1] x86: Support ZHAOXIN GMI instructions

mayshao-oc mayshao-oc@zhaoxin.com
Mon Oct 14 09:05:08 GMT 2024


Hi Haochen:
      Thanks for your comment. You are right, I need to use prefix to 
distinguish  montmul/sm2. For the sm2 instruction, 0c is modrm byte.
      As to the function name, I need to skip repz display for sm3 and 
sm4 instruction, and I want to use OP_Skip_REPZ as function name, do you 
think its make sense.

Best Regards
Mayshao


On 10/14/24 16:37, Jiang, Haochen wrote:
> 
> 
> 
>> From: Jan Beulich <jbeulich@suse.com>
>> Sent: Monday, October 14, 2024 2:54 PM
>>
>> In i386-dis.c, if - following earlier comments - you still need some fixup
>> function(s), please name them suitably. The pre-existing OP_0f07() is
>> grossly misnamed, and that misnaming shouldn't be further extended.
> 
> As Jan said, OP_0f07 is misnamed.
> 
> But I suppose OP_Skip_MODRM might be better here if you still believe
> they are not modrm bytes, just like mentioned LFENCE and SFENCE example.
> 
> I am not sure if they should be changed to this, you could have a try on that.
> 
> Thx,
> Haochen
> 
>>
>> Jan


More information about the Binutils mailing list