[PATCH 02/11] arm: rename FPU_ARCH_VFP to FPU_ARCH_SOFTVFP
Richard Earnshaw
rearnsha@arm.com
Mon Jun 3 11:49:03 GMT 2024
FPU_ARCH_VFP has always meant VFP floating-point format (natural FP
word order) but without any VFP instructions. But the name
FPU_ARCH_VFP is potentially confusing. This patch just changes the
name to make the meaning clearer.
---
gas/config/tc-arm.c | 146 ++++++++++++++++++++++-------------
gas/config/te-armeabi.h | 2 +-
gas/config/te-armfbsdvfp.h | 2 +-
gas/config/te-armlinuxeabi.h | 2 +-
gas/config/te-nacl.h | 2 +-
include/opcode/arm.h | 2 +-
6 files changed, 97 insertions(+), 59 deletions(-)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0002-arm-rename-FPU_ARCH_VFP-to-FPU_ARCH_SOFTVFP.patch
Type: text/x-patch
Size: 11331 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20240603/00e0bade/attachment-0001.bin>
More information about the Binutils
mailing list