[PATCH v2 0/3] gas: add command line option to inhibit info messages

Matthieu Longo matthieu.longo@arm.com
Tue Jul 9 09:10:23 GMT 2024


On 2024-07-09 08:40, Jan Beulich wrote:
> On 04.07.2024 17:51, Matthieu Longo wrote:
>> Hi,
>>
>> GAS currently emits information messages for context information along warnings. These extra messages might sometimes pollute the test expectations when checking for error message patterns in stderr output.
>>
>> This patch aims at providing two new flags while preserving the existing behavior if none of the options is provided.
>>    * --info, similar to the existing --warn flag to enable diagnostic information messages (default behavior).
>>    * --no-info, similar to the existing --no-warn flag to disable diagnostic information messages.
>>
>> It also adds the flags to the existing documentation, and command manual.
>>
>> As an example of its benefit, I used the new flag for the system register tests under gas/testsuite/gas/aarch64/sysreg testsuite, and the info message for macro expansion were removed inside the tests expectations.
>>
>> Regression tested on aarch64-none-elf, and no regression found.
>>
>> Ok for binutils-master?
>>
>> Regards,
>> Matthieu.
>>
>> Changes from v0:
>> - reorder warning options
>>    https://sourceware.org/pipermail/binutils/2024-June/135232.html
>> - rename flag_no_infos to flag_no_information.
>> - documentation: move --no-info and --info flags after warnings flags.
>> - remove from this patch's scope the tests relying on the line number.
>>    add a check in output_info() in AArch64 backend.
>>    check flag_no_information flag and quickly return if enabled, as requested in the previous revision's review.
>>    https://sourceware.org/pipermail/binutils/2024-June/135231.html
>>
>> Changes from v1:
>> - move the '--info' section up to respect alphabetical order.
> 
> I'm a little puzzled here: Checking patch 2, I think I see only a single
> place where such movement was actually done. Did you maybe send a stale
> patch?
> 
> Jan

Hi Jan,

In a previous review, you mentioned:
 > In all of the doc changes you appear to be entirely ignoring the present
 > alphabetical sorting in the blocks you insert into. The info additions
 > want to all move further up; the sorting there isn't on a "related to one
 > another" basis afaics.

I moved the info additions further up to respect the alphabetical order 
as you requested.
Everything else seems to fit into place from my perspective. I probably 
misunderstood what you meant.
Please could you be more specific to what else should be moved and where 
by pointing it directly in the patch ?

Matthieu


More information about the Binutils mailing list