[PATCH] elf: Rename is_standard_elf to uses_elf_em
Nick Clifton
nickc@redhat.com
Fri Jan 26 15:25:48 GMT 2024
Hi H.J.
> Rename is_standard_elf to uses_elf_em for targets which use elf.em.
>
> binutils/
>
> PR ld/31289
> * testsuite/lib/binutils-common.exp (is_standard_elf): Renamed
> to ...
> (uses_elf_em): This.
>
> ld/
>
> PR ld/31289
> * testsuite/ld-elf/fatal-warnings-2a.d: Replace is_standard_elf
> with uses_elf_em.
> * testsuite/ld-elf/fatal-warnings-2b.d: Likewise.
> * testsuite/ld-elf/fatal-warnings-3a.d: Likewise.
> * testsuite/ld-elf/fatal-warnings-3b.d: Likewise.
> * testsuite/ld-elf/fatal-warnings-4a.d: Likewise.
Approved - please apply.
Cheers
Nick
More information about the Binutils
mailing list