[PATCH 2/8] Support APX GPR32 with extend evex prefix

Jan Beulich jbeulich@suse.com
Tue Oct 17 16:11:13 GMT 2023


On 17.10.2023 17:50, Cui, Lili wrote:
>>> +  /* PREFIX_EVEX_MAP4_60 */
>>> +  {
>>> +    { "movbeS",	{ Gv, Ev }, 0 },
>>> +    { Bad_Opcode },
>>> +    { "movbeS",	{ Gv, Ev }, 0 },
>>> +  },
>>> +  /* PREFIX_EVEX_MAP4_61 */
>>> +  {
>>> +    { "movbeS",	{ Ev, Gv }, 0 },
>>> +    { Bad_Opcode },
>>> +    { "movbeS",	{ Ev, Gv }, 0 },
>>> +  },
>>
>> In cases like this (of which, aiui, there will be many more), where only prefix
>> 66 is valid, and only to modify operand size, it would be quite desirable to
>> have a new PREFIX_... identifier to use in the parent table entry, such that this
>> additional decode step can be avoided.
>>
> 
> Added PREFIX_DATA_AND_NP_ONLY to report bad for f2 and f3 prefix. Do you have a better name for the new PREFIX ?

If PREFIX_DATA itself cannot suitable be re-used here, maybe PREFIX_NP_OR_DATA?

Jan


More information about the Binutils mailing list