[PATCH 1/8] Support APX GPR32 with rex2 prefix
Jan Beulich
jbeulich@suse.com
Fri Nov 3 13:05:03 GMT 2023
On 02.11.2023 18:05, Jan Beulich wrote:
> (for now only comments on i386-gen.c changes)
>
> On 02.11.2023 12:29, Cui, Lili wrote:
>> @@ -1008,10 +1012,35 @@ get_element_size (char **opnd, int lineno)
>> return elem_size;
>> }
>>
>> +static bool
>> +if_entry_needs_special_handle (const unsigned long long opcode, unsigned int space,
>> + const char *cpu_flags)
>
> This function wants to be named after its purpose, e.g. rex2_disallowed()
> with its current return value arrangement. "needs special handling" is a
> term that might be okay now, but what if you gus come up with REX3 in a
> few years time which then again needs (a different kind of) special
> handling?
Actually, depending on its significance for later changes, egpr_disallowed()
might be a (longterm) better name.
Jan
More information about the Binutils
mailing list