[PATCH 1/2] opcodes/mips: use .word/.short for undefined instructions

Andrew Burgess aburgess@redhat.com
Mon Jan 30 09:34:58 GMT 2023


"Maciej W. Rozycki" <macro@orcam.me.uk> writes:

> On Tue, 17 Jan 2023, Andrew Burgess wrote:
>
>> Sorry for the time taken to prepare this patch.  Let me know if you're
>> happy for my to push the below, or if there's anything else that's
>> needed.
>
>  This is mostly OK, thank you, but see below.
>
>> diff --git a/binutils/testsuite/binutils-all/mips/mips.exp b/binutils/testsuite/binutils-all/mips/mips.exp
>> index 6a0ec25a06f..f43109a75b8 100644
>> --- a/binutils/testsuite/binutils-all/mips/mips.exp
>> +++ b/binutils/testsuite/binutils-all/mips/mips.exp
>> @@ -266,3 +266,7 @@ run_dump_test_n64 "global-local-symtab-sort-n64${tmips}"
>>  run_dump_test_o32 "global-local-symtab-final-o32" useld
>>  run_dump_test_n32 "global-local-symtab-final-n32" useld
>>  run_dump_test_n64 "global-local-symtab-final-n64" useld
>> +
>> +run_dump_test_o32 "micromips-reserved-enc"
>> +run_dump_test_n32 "micromips-reserved-enc"
>> +run_dump_test_n64 "micromips-reserved-enc"
>
>  Our convention has been not to have duplicate test names, so please 
> create separate .d files for each of these three tests (we have no better 
> way at the moment, although one could envisage appending the ABI name 
> automatically).  See e.g. global-local-symtab-sort-n32.d in the same 
> directory and the `source' and `dump' keywords within for how you can 
> avoid duplicating identical sources and dumps.
>
>> diff --git a/opcodes/mips-dis.c b/opcodes/mips-dis.c
>> index 6a513cd8946..80c35f4a5e0 100644
>> --- a/opcodes/mips-dis.c
>> +++ b/opcodes/mips-dis.c
>> @@ -2601,11 +2601,19 @@ print_insn_micromips (bfd_vma memaddr, struct disassemble_info *info)
>>      }
>>  
>>    if (length == 2)
>> -    infprintf (is, dis_style_assembler_directive, ".short");
>> +    {
>> +      infprintf (is, dis_style_assembler_directive, ".short");
>> +      infprintf (is, dis_style_text, "\t");
>> +      infprintf (is, dis_style_immediate, "0x%x", insn);
>> +    }
>>    else
>> -    infprintf (is, dis_style_assembler_directive, ".word");
>> -  infprintf (is, dis_style_text, "\t");
>> -  infprintf (is, dis_style_immediate, "0x%x", insn);
>> +    {
>> +      infprintf (is, dis_style_assembler_directive, ".short");
>> +      infprintf (is, dis_style_text, "\t");
>> +      infprintf (is, dis_style_immediate, "0x%x", (insn >> 16) & 0xffff);
>> +      infprintf (is, dis_style_text, ", ");
>> +      infprintf (is, dis_style_immediate, "0x%x", (insn & 0xffff));
>> +    }
>
>  Now that I have looked at it again I've been wondering if:
>
>   infprintf (is, dis_style_assembler_directive, ".short");
>   infprintf (is, dis_style_text, "\t");
>   if (length != 2)
>     {
>       infprintf (is, dis_style_immediate, "0x%x", (insn >> 16) & 0xffff);
>       infprintf (is, dis_style_text, ", ");
>     }
>   infprintf (is, dis_style_immediate, "0x%x", (insn & 0xffff));
>
> might be more desirably avoiding some code duplication, but I'll leave it 
> up to you to decide if to keep your original proposal or whether to switch 
> to this alternative.


Maciej,

Thanks for your continues feedback.

I've updated the patch.  Let me know what you think.

Thanks,
Andrew

---

commit fe08c994fa9431909a6e63582b0a7f4c34f6e826
Author: Andrew Burgess <aburgess@redhat.com>
Date:   Fri Jan 6 16:42:23 2023 +0000

    opcodes/mips: disassemble unknown micromips instructions as two shorts
    
    Before commit:
    
      commit 2438b771ee07be19d5b01ea55e077dd8b7cef445
      Date:   Wed Nov 2 15:53:43 2022 +0000
    
          opcodes/mips: use .word/.short for undefined instructions
    
    unknown 32-bit microMIPS instructions were disassembled as a raw
    32-bit number with no '.word' directive.  The above commit changed
    this and added a '.word' directive before the 32-bit number.
    
    It was pointed out on the mailing list, that for microMIPS it would be
    better to display such 32-bit instructions using a '.short' directive
    followed by two 16-bit values.
    
    This commit updates the mips disassembler to do this, and adds a new
    test that validates this output.

diff --git a/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n32.d b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n32.d
new file mode 100644
index 00000000000..e6608f30265
--- /dev/null
+++ b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n32.d
@@ -0,0 +1,5 @@
+#PROG: objcopy
+#objdump: -d --prefix-addresses --show-raw-insn
+#name: microMIPS source file contains reserved encoding (n32)
+#source: micromips-reserved-enc.s
+#dump: micromips-reserved-enc-o32.d
diff --git a/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n64.d b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n64.d
new file mode 100644
index 00000000000..f892bfabbe7
--- /dev/null
+++ b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-n64.d
@@ -0,0 +1,5 @@
+#PROG: objcopy
+#objdump: -d --prefix-addresses --show-raw-insn
+#name: microMIPS source file contains reserved encoding (n64)
+#source: micromips-reserved-enc.s
+#dump: micromips-reserved-enc-o32.d
diff --git a/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-o32.d b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-o32.d
new file mode 100644
index 00000000000..3de3989b37a
--- /dev/null
+++ b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc-o32.d
@@ -0,0 +1,10 @@
+#PROG: objcopy
+#objdump: -d --prefix-addresses --show-raw-insn
+#name: microMIPS source file contains reserved encoding (o32)
+#source: micromips-reserved-enc.s
+
+.*: +file format .*mips.*
+
+Disassembly of section \.text:
+[0-9a-f]+ <[^>]*> 7f6e 5d4c 	\.short	0x7f6e, 0x5d4c
+	\.\.\.
diff --git a/binutils/testsuite/binutils-all/mips/micromips-reserved-enc.s b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc.s
new file mode 100644
index 00000000000..59f0f763964
--- /dev/null
+++ b/binutils/testsuite/binutils-all/mips/micromips-reserved-enc.s
@@ -0,0 +1,4 @@
+	.module	micromips
+foo:
+	.insn
+	.short	0x7f6e, 0x5d4c
diff --git a/binutils/testsuite/binutils-all/mips/mips.exp b/binutils/testsuite/binutils-all/mips/mips.exp
index 6a0ec25a06f..91bf3274592 100644
--- a/binutils/testsuite/binutils-all/mips/mips.exp
+++ b/binutils/testsuite/binutils-all/mips/mips.exp
@@ -266,3 +266,7 @@ run_dump_test_n64 "global-local-symtab-sort-n64${tmips}"
 run_dump_test_o32 "global-local-symtab-final-o32" useld
 run_dump_test_n32 "global-local-symtab-final-n32" useld
 run_dump_test_n64 "global-local-symtab-final-n64" useld
+
+run_dump_test_o32 "micromips-reserved-enc-o32"
+run_dump_test_n32 "micromips-reserved-enc-n32"
+run_dump_test_n64 "micromips-reserved-enc-n64"
diff --git a/opcodes/mips-dis.c b/opcodes/mips-dis.c
index 6a513cd8946..859d4e3806f 100644
--- a/opcodes/mips-dis.c
+++ b/opcodes/mips-dis.c
@@ -2600,12 +2600,15 @@ print_insn_micromips (bfd_vma memaddr, struct disassemble_info *info)
 	}
     }
 
-  if (length == 2)
-    infprintf (is, dis_style_assembler_directive, ".short");
-  else
-    infprintf (is, dis_style_assembler_directive, ".word");
+  infprintf (is, dis_style_assembler_directive, ".short");
   infprintf (is, dis_style_text, "\t");
-  infprintf (is, dis_style_immediate, "0x%x", insn);
+  if (length != 2)
+    {
+      infprintf (is, dis_style_immediate, "0x%x", (insn >> 16) & 0xffff);
+      infprintf (is, dis_style_text, ", ");
+    }
+  infprintf (is, dis_style_immediate, "0x%x", (insn & 0xffff));
+
   info->insn_type = dis_noninsn;
 
   return length;



More information about the Binutils mailing list