Rename bfd_bread and bfd_bwrite
Alexandra Petlanova Hajkova
ahajkova@redhat.com
Tue Aug 15 10:02:24 GMT 2023
On Wed, Aug 9, 2023 at 1:28 AM Alan Modra via Gdb-patches <
gdb-patches@sourceware.org> wrote:
> These were renamed from bfd_read and bfd_write back in 2001 when they
> lost an unnecessary parameter. Rename them back, and get rid of a few
> casts that are only needed without prototyped functions (K&R C).
>
>
> This patch haven't applied cleanly for me, it may need a rebase.
>
I tested it on x86_64 Fedora Rawhide and I can see no regressions.
>
>
>
>
>
>
>
>
More information about the Binutils
mailing list