[PATCH v2 0/8] RISC-V: Various opcode tidying (batch 1)

Tsukasa OI research_trasio@irq.a4lg.com
Wed Oct 19 13:11:54 GMT 2022


Hello,

This patchset contains various tidying of RISC-V opcodes that would...

(a) Make coding style more consistent and/or more readable
(b) Remove unused constants
(c) Make new instruction names primary (clean old names except aliases)
(d) Make opcode entries functionally consistent.

I call this "batch 1" and deals with the most obvious (yet small and
various) issues.


[Overview of this Patchset]

PATCH 1/8: (a) Tidying (add space at the tail of pinfo)
PATCH 2/8: (a) Tidying (fix obvious misalignments on 'Zbb'/'Zba')
PATCH 3/8: (a) Tidying (remove spaces around "|" operator)
PATCH 4/8: (b) Remove unused instruction macros
PATCH 5/8: (c) SCALL -> ECALL, SBREAK -> EBREAK        (RISC-V ISA v2.1)
PATCH 6/8: (c) FMV.S.X -> FMV.W.X, FMV.X.S -> FMV.X.W  (RISC-V ISA v2.2)
PATCH 7/8: (c) Make old instruction names aliases
PATCH 8/8: (d) Use defined (and named) constants for instruction defining


Thanks,
Tsukasa




Tsukasa OI (8):
  RISC-V: Add a space at the end of pinfo
  RISC-V: Fix obvious misalignments ('Zbb'/'Zba')
  RISC-V: Remove spaces in opcode entries
  RISC-V: Remove unused instruction macros
  RISC-V: Complete tidying up with SCALL and SBREAK
  RISC-V: Tidying up with fmv.w.x and fmv.x.w
  RISC-V: Make alias instructions aliases
  RISC-V: Use defined mask and match values

 include/opcode/riscv-opc.h |  47 +--
 opcodes/riscv-opc.c        | 706 ++++++++++++++++++-------------------
 2 files changed, 359 insertions(+), 394 deletions(-)


base-commit: 2b06e59de0675c2cb526af2de6803dae29703d15
-- 
2.34.1



More information about the Binutils mailing list