[PATCH 4/5] opcodes/riscv-dis.c: Make XLEN variable static

Tsukasa OI research_trasio@irq.a4lg.com
Sat Oct 8 04:34:26 GMT 2022


Before changing the core disassembler, we take care of minor code clarity
issues and improve readability.

Since xlen variable is not (and should not) used outside riscv-dis.c,
this commit makes this variable static.

opcodes/ChangeLog:

	* riscv-dis.c (xlen): Make this variable static.
---
 opcodes/riscv-dis.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/opcodes/riscv-dis.c b/opcodes/riscv-dis.c
index 608670bed7f..27e1978d428 100644
--- a/opcodes/riscv-dis.c
+++ b/opcodes/riscv-dis.c
@@ -33,7 +33,7 @@
 #include <ctype.h>
 
 /* Current XLEN for the disassembler.  */
-unsigned xlen = 0;
+static unsigned xlen = 0;
 
 /* Default ISA specification version (constant as of now).  */
 static enum riscv_spec_class default_isa_spec = ISA_SPEC_CLASS_DRAFT - 1;
-- 
2.34.1



More information about the Binutils mailing list