[PATCH][Binutils][GAS] arm: Fix system register fpcxt_ns and fpcxt_s naming convention.

Nick Clifton nickc@redhat.com
Wed May 18 15:41:47 GMT 2022


Hi Srinath,

> The current assembler accepts system registers FPCXTNS and FPCXTS for Armv8.1-M
> Mainline Instructions VSTR, VLDR, VMRS and VMSR.
> Assembler should be also allowing FPCXT_NS, fpcxt_ns, fpcxtns, FPCXT_S, fpcxt_s
> and fpcxts. This patch fixes the issue.
> 
> Regression testing for arm-none-eabi target and found no regressions.
> 
> Ok for binutils-master?

Approved - please apply.

Cheers
   Nick



More information about the Binutils mailing list